Use a Cisco IOS Switch to Serve DHCP to Avaya Phones

Avaya VoIP phones require a special option in a DHCP scope, so they know how to make calls. There may be times where it is desirable to have the DHCP running on a piece of networking equipment on a remote site, so that a separate server is not needed for the role. In this example there are two VLANs on each port of a Cisco switch running IOS. VLAN 52 is for user traffic, and VLAN 222 is for the VoIP traffic.

You would want to configure your ports to look something like:

interface GigabitEthernet1/1
switchport
switchport access vlan 52
switchport mode access
switchport voice vlan 222
mls qos trust cos

The VLAN interfaces would look like:

interface Vlan52
ip address 172.16.52.2 255.255.255.0
!
interface Vlan222
ip address 172.16.222.2 255.255.255.0

Now that the interfaces are all configured, also make sure that they aren't administratively down. You can make sure they are not administratively down by configuring “no shutdown” under each interface. To confirm the interfaces are up, use “show ip interfaces brief”.
Since there are two VLANs, we will need two DHCP scopes. The user VLAN (52):

ip dhcp pool 2ndFloorCorp
network 172.16.52.0 255.255.255.0
dns-server 172.16.244.214 172.16.244.202
domain-name techsneeze.com
default-router 172.16.52.1
netbios-name-server 172.16.19.31 172.16.18.31
option 176 ascii "TFTPSRVR=172.16.244.189,MCIPADD=172.16.104.11,MCPORT=1719,L2Q=1,L2QVLAN=222,L2QAUD=5,L2QSIG=3"
!

The most important piece is the line with “option 176…” You will notice that there is a “L2QVLAN=222”. This means that the phone will boot and get the DHCP scope from the access VLAN (52) and be told to switch to VoIP VLAN (222).
Next we'll configure the VoIP VLAN (222) DHCP scope:

ip dhcp pool 2ndFloorVoIP
network 172.16.222.0 255.255.255.0
dns-server 172.16.244.214 172.16.244.202
domain-name techsneeze.com
default-router 172.16.222.1
netbios-name-server 172.16.19.31 172.16.18.31
option 176 ascii "TFTPSRVR=172.16.244.189,MCIPADD=172.16.104.11,MCPORT=1719"
!

By default the Cisco DHCP service will give Ips out for the entire block configured. Since we are bound to have some static IPs in each block, we need to setup exclusions

ip dhcp excluded-address 172.16.52.0 172.16.52.35
ip dhcp excluded-address 172.16.222.0 172.16.222.20

Finally, we need to enable the DHCP service.

service dhcp

avaya, cisco, phones, dhcp, voip, vlans

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.